Get Satisfaction Education Center

Home > Community Task Guide > Configure The Community > Supported Browsers

Supported Browsers

Currently, we officially support the following browsers (by application):

New Community Application

  • Chrome (latest)
  • Firefox (latest)
  • Safari (latest)
  • Internet Explorer 9+
  • iOS 7+ (Safari)
  • Android 4+ (Android browser)

Manage Workspace

  • Chrome (latest)
  • Firefox (latest)
  • Safari (latest)
  • Internet Explorer 9+
  • Internet Explorer 8 (some visual design inconsistencies)

Legacy Community Application

  • Chrome (latest)
  • Firefox (latest)
  • Safari (latest)
  • Internet Explorer 8+

Engage Widgets

  • Chrome (latest)
  • Firefox (latest)
  • Safari (latest)
  • Internet Explorer 8+

Our platform, widgets, and the mobile version of your community will typically work in other browsers, however these are the ones we officially test and support.

System Status

Company Updates